NEXUS 5K – ENABLE LACP – SERVER NIC TEAM LOAD BALANCING using HP Config Utility

This configuration needs to go under “configure sync” in order for it to sync over to the HA Pair.
Run “show switch-profile status” in order to check for “Profile-Revision” and have configuration
put on the hardware with the highest revision no. If the lower revision no. HA pair is used it will
not be accepted and will not sync configuration over to other HA pair.

This configuration allows the two Ethernet1221/1/1Ethernet1222/1/1 ports where the server is
directly connected with 2 seperate Nics, in order to provide load balancing using the LACP
etherchanneling technology.

The server is using a HP Network Config utility in order to team the network adapters together and
is put in auto mode in order to detect the LACP off the nexus switches.

The feature here it uses is “802.3ad Dynamic with Fault Tolerance“.
The can be seen on the HP utility under statistics and the Speed/Duplex as well as calculated throughput.

 

configure sync
switch-profile OSYS
!
interface port-channel205
description DERRRESYNCBC04
switchport access vlan 704
spanning-tree port type edge
!
interface Ethernet121/1/1
switchport access vlan 704
spanning-tree port type edge
channel-group 205 mode active
!
interface Ethernet122/1/1
switchport access vlan 704
spanning-tree port type edge
channel-group 205 mode active
!
!
verify
commit
!
!

Diagnostics :

show port-channel summary

205   Po205(SU)   Eth      LACP      Eth121/1/1(P)  Eth122/1/1(P)

!

show interface Eth121/1/1

Ethernet121/1/1 is up
Hardware: 100/1000 Ethernet, address: d4a0.2aff.c0c2 (bia d4a0.2aff.c0c2)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
!

show interface Eth122/1/1

Ethernet122/1/1 is up
  Hardware: 100/1000 Ethernet, address: 04da.d2d7.98c2 (bia 04da.d2d7.98c2)
  MTU 1500 bytes, BW 1000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255
!
!

show interface port-channel 205

port-channel205 is up
 vPC Status: Up, vPC number: 262348
  Hardware: Port-Channel, address: d4a0.2aff.c0c2 (bia d4a0.2aff.c0c2)
  Description: DERRRESYNCBC04
  MTU 1500 bytes, BW 2000000 Kbit, DLY 10 usec
  reliability 255/255, txload 1/255, rxload 1/255

 

HP Teaming Tool