Networking-Blog

My WordPress Blog

Enable the Web Interface for uTorrent

The uTorrent bittorrent client has a web interface which allows you to control uTorrent with a web browser. This means you can control uTorrent while you are out and about or, in my case, from an upstairs laptop when the actual download is happening in my downstairs office. This post looks at how to enable the web interface for uTorrent version 1.7.7. It should work for all 1.7 versions.

According to the forum post about the uTorrent web interface, IE 6 is not supported; it’s in really big red text so I guess they mean it! I have successfully used the web interface with IE7, Firefox 2 and Opera 9.5.

Select “Options” then “Preferences” from the uTorrent main menu and you will see a preferences dialog like the one below. Select the “Advanced” then “Web UI” section to get to the web interface settings as show below.

utorrent-webui-1

You need to tick the “Enable Web Interface” checkbox as shown and should then specify a username and password. You can leave the “Alternative listening port” checkbox unchecked and connect via your web browser to the same port that bittorrent runs as, or check it and specify you own port as I have done in the above example.

Unfortunately it’s not as simple as that… 

The next thing you need to do is download the Web UI files from the uTorrent website. Once you extracted them, you need to save the webui.zip file to the following location:

%AppData%\uTorrent

To navigate there, either select “Start” then “Run” or enter the above into the address bar of Windows Explorer. It will automatically change the %AppData% placeholder to the appropriate folder.

Now it will work. Open up your web browser and go to e.g. http://192.168.1.10:8080/gui where 192.168.1.10 is your computer’s IP address (“localhost” may work, but didn’t for me on Vista) and 8080 is the bittorrent port or the port specified in the settings above. After entering your login name and password, you will see something like this:

utorrent-webui-2
If you go to e.g. http://192.168.1.10:8080/ then you’ll get the message “invalid request” so make sure you include the “gui” part at the end. If you enable the web interface in the uTorrent settings but don’t put the zip file into the appropriate folder you’ll still get the “invalid request” message at the root level, but the “gui” level will just have a blank page. So make sure you save the zip file to the correct place and navigate to e.g. http://192.168.1.10:8080/gui

Hello world!

Highly proficient CCNA, CCNP, CCSP, MCSE Certified, BSC (hons) Business IT Graduate.

Currently completed my CCNASP ( Service Provider ) as well has BIG IP F5 – Load Balancers – Administration, TMOS Administration. Has 18 years experience acquired in a series of demanding roles in the IT sector.

Most recently worked as a Senior Network architect Engineer at HP Data Center. Now seeking next rewarding and challenging opportunity in a successful professional environment. Highly motivated and enthusiastic with good communication skills. Excellent time keeping. Determined to become a critical part of an organization’s success.

Whilst at Siemens PLC I have held a Senior position in Infrastructure Network Engineering and also being part of all escalations in the day to day running of major networks to manage and maintaining our core solutions which has really given me a broad understanding of how network communication businesses operate in today’s climate.

OSPF ROUTE FILTERING WITHIN AREA

There are two points at which OSPF routes can be filtered: within an area, or between areas on an
area border router (ABR).

This article discusses the differences between the two and the considerations which
should be made when implementing OSPF filtering.

The following topology is provided for illustration of both cases:

#### AREA0                                               #### AREA1

The 172.16.7.0/24 network has been implemented on R3 for testing. The route is intended only to be
propagated throughout the local area 1, but is currently being advertised to the entire OSPF domain.

(as indicated by the green arrows in the topology):

R3# show ip route

C 172.16.4.0/24 is directly connected, FastEthernet0/1
C 172.16.5.0/24 is directly connected, Loopback0
C 172.16.7.0/24 is directly connected, Loopback1
O IA 172.16.1.1/32 [110/20] via 172.16.4.1, 00:11:06, FastEthernet0/1
O IA 172.16.3.1/32 [110/21] via 172.16.4.1, 00:06:33, FastEthernet0/1
O IA 172.16.2.0/24 [110/21] via 172.16.4.1, 00:06:33, FastEthernet0/1

We can implement inter-area filtering (filtering between areas) on R2 to prevent the route from being
advertised outside of area 1. First, we define a prefix list on R2 to deny the 172.16.7.1/24 prefix and allow all others:

ip prefix-list FILTER seq 5 deny 172.16.7.1/32
ip prefix-list FILTER seq 10 permit 0.0.0.0/0 le 32
!

R2 :

router ospf 1
log-adjacency-changes
area 1 filter-list prefix FILTER out
network 172.16.2.2 0.0.0.0 area 0
network 172.16.3.1 0.0.0.0 area 0
network 172.16.4.1 0.0.0.0 area 1
!
Appending le 32 to the first prefix list entry ensures that any more-specific routes within 172.16.7.0/24 are denied as well (as opposed to only the exact /24 route).

Complete Configuration :

R1 :

interface Loopback0
ip address 172.16.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.2.1 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 172.16.1.1 0.0.0.0 area 0
network 172.16.2.1 0.0.0.0 area 0
!
!

R2 :

interface Loopback0
ip address 172.16.3.1 255.255.255.0
!
interface FastEthernet0/0
ip address 172.16.2.2 255.255.255.0
!
interface FastEthernet0/1
ip address 172.16.4.1 255.255.255.0
!
!
router ospf 1
log-adjacency-changes
area 1 filter-list prefix FILTER out
network 172.16.2.2 0.0.0.0 area 0
network 172.16.3.1 0.0.0.0 area 0
network 172.16.4.1 0.0.0.0 area 1
!
!

R3 :

interface Loopback0
ip address 172.16.5.1 255.255.255.0
!
interface Loopback1
ip address 172.16.7.1 255.255.255.0
!
interface FastEthernet0/1
ip address 172.16.4.2 255.255.255.0
!
router ospf 1
log-adjacency-changes
network 172.16.4.2 0.0.0.0 area 1
network 172.16.5.1 0.0.0.0 area 1
network 172.16.7.1 0.0.0.0 area 1

 

Distribute-lists do not work for outbound OSPF filtering (even though the CLI may accept the command)
as OSPF is a link-state protocol and thus all routers within an area must flood all LSAs.